import re
regex = re.compile(r"N([1-9][0-9]{0,3}[A-HJ-NP-Z]{2}|[1-9][0-9]{0,3}[A-HJ-NP-Z]|[1-9][0-9]{0,4})", flags=re.MULTILINE)
test_str = ("Should Match\n"
"N12345\n"
"N1234Z\n"
"N123AZ\n"
"N1\n"
"N99\n\n"
"Should not match\n"
"N01Z\n"
"N12PI\n"
"N56OT")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")