using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"N([1-9][0-9]{0,3}[A-HJ-NP-Z]{2}|[1-9][0-9]{0,3}[A-HJ-NP-Z]|[1-9][0-9]{0,4})";
string input = @"Should Match
N12345
N1234Z
N123AZ
N1
N99
Should not match
N01Z
N12PI
N56OT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}