import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<label for=\\\"(.*?)\\\" ?\\>(.*?)\\<br ?\\/?>";
final String string = "<label for=\"user_login\" >Username or Email Address<br />";
final String subst = "<label for=\"$2\"><span class=\"label-text\">$1</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}