// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<label for=\"(.*?)\" ?\>(.*?)\<br ?\/?>"#).unwrap();
let string = "<label for=\"user_login\" >Username or Email Address<br />";
let substitution = "<label for=\"$2\"><span class=\"label-text\">$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}