const regex = /<label for=\"(.*?)\" ?\>(.*?)\<br ?\/?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<label for=\\"(.*?)\\" ?\\>(.*?)\\<br ?\\\/?>', 'g')
const str = `<label for="user_login" >Username or Email Address<br />`;
const subst = `<label for="$2"><span class="label-text">$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);