$re = '/<label for=\"(.*?)\" ?\>(.*?)\<br ?\/?>/';
$str = '<label for="user_login" >Username or Email Address<br />';
$subst = "<label for=\"$2\"><span class=\"label-text\">$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;