re = /<label for=\"(.*?)\" ?\>(.*?)\<br ?\/?>/
str = '<label for="user_login" >Username or Email Address<br />'
subst = '<label for="$2"><span class="label-text">$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result