import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(0[0-7]+))|(?=(0(x|X)[A-F\\da-f]+))|(?=((\\-|\\+|)[1-9]\\d*))(?=(\\d+\\.\\d+))$";
final String string = "0x234fA\n"
+ "0X234fA\n"
+ "07245\n"
+ "00\n"
+ "56789\n"
+ "20\n"
+ "+20\n"
+ "-20\n"
+ "0.0\n"
+ "20.10\n"
+ "+20.10\n"
+ "-20.10\n"
+ "-20.34.56\n"
+ "20.10e10\n"
+ "-20.10e10\n"
+ "20.10e-10\n"
+ "-20.10e-10\n"
+ "20.10E10\n"
+ "-20.10E10\n"
+ "20.10E-10\n"
+ "-20.10E-10\n\n"
+ "+20.10e10\n"
+ "+20.10e-10\n"
+ "+20.10E10\n"
+ "+20.10E-10\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}