const regex = new RegExp('^(?=(0[0-7]+))|(?=(0(x|X)[A-F\\da-f]+))|(?=((\\-|\\+|)[1-9]\\d*))(?=(\\d+\\.\\d+))$', 'mg')
const str = `0x234fA
0X234fA
07245
00
56789
20
+20
-20
0.0
20.10
+20.10
-20.10
-20.34.56
20.10e10
-20.10e10
20.10e-10
-20.10e-10
20.10E10
-20.10E10
20.10E-10
-20.10E-10
+20.10e10
+20.10e-10
+20.10E10
+20.10E-10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}