$re = '/^(?=(0[0-7]+))|(?=(0(x|X)[A-F\da-f]+))|(?=((\-|\+|)[1-9]\d*))(?=(\d+\.\d+))$/m';
$str = '0x234fA
0X234fA
07245
00
56789
20
+20
-20
0.0
20.10
+20.10
-20.10
-20.34.56
20.10e10
-20.10e10
20.10e-10
-20.10e-10
20.10E10
-20.10E10
20.10E-10
-20.10E-10
+20.10e10
+20.10e-10
+20.10E10
+20.10E-10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);