import re
regex = re.compile(r"^(?=(0[0-7]+))|(?=(0(x|X)[A-F\da-f]+))|(?=((\-|\+|)[1-9]\d*))(?=(\d+\.\d+))$", flags=re.MULTILINE)
test_str = ("0x234fA\n"
"0X234fA\n"
"07245\n"
"00\n"
"56789\n"
"20\n"
"+20\n"
"-20\n"
"0.0\n"
"20.10\n"
"+20.10\n"
"-20.10\n"
"-20.34.56\n"
"20.10e10\n"
"-20.10e10\n"
"20.10e-10\n"
"-20.10e-10\n"
"20.10E10\n"
"-20.10E10\n"
"20.10E-10\n"
"-20.10E-10\n\n"
"+20.10e10\n"
"+20.10e-10\n"
"+20.10E10\n"
"+20.10E-10\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")