import Foundation
let pattern = #"^(?=(0[0-7]+))|(?=(0(x|X)[A-F\da-f]+))|(?=((\-|\+|)[1-9]\d*))(?=(\d+\.\d+))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0x234fA
0X234fA
07245
00
56789
20
+20
-20
0.0
20.10
+20.10
-20.10
-20.34.56
20.10e10
-20.10e10
20.10e-10
-20.10e-10
20.10E10
-20.10E10
20.10E-10
-20.10E-10
+20.10e10
+20.10e-10
+20.10E10
+20.10E-10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)