#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*([.,']).*\1)[a-zA-Z.,']*$"
Local $sString = "String.,'" & @CRLF & _
"y.yy" & @CRLF & _
".bb,b" & @CRLF & _
"y,yyy." & @CRLF & _
".b'bb" & @CRLF & _
"bbb'" & @CRLF & _
"a,y." & @CRLF & _
"" & @CRLF & _
"a,z,f" & @CRLF & _
"y.t.e" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")