import re
regex = re.compile(r"^(?!.*([.,']).*\1)[a-zA-Z.,']*$", flags=re.MULTILINE)
test_str = ("String.,'\n"
"y.yy\n"
".bb,b\n"
"y,yyy.\n"
".b'bb\n"
"bbb'\n"
"a,y.\n\n"
"a,z,f\n"
"y.t.e\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")