re = /^(?!.*([.,']).*\1)[a-zA-Z.,']*$/m
str = 'String.,\'
y.yy
.bb,b
y,yyy.
.b\'bb
bbb\'
a,y.
a,z,f
y.t.e
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end