import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([.,']).*\\1)[a-zA-Z.,']*$";
final String string = "String.,'\n"
+ "y.yy\n"
+ ".bb,b\n"
+ "y,yyy.\n"
+ ".b'bb\n"
+ "bbb'\n"
+ "a,y.\n\n"
+ "a,z,f\n"
+ "y.t.e\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}