$re = '/^(?!.*([.,\']).*\1)[a-zA-Z.,\']*$/m';
$str = 'String.,\'
y.yy
.bb,b
y,yyy.
.b\'bb
bbb\'
a,y.
a,z,f
y.t.e
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);