#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?[0-9]{1,3}(?: ?[0-9]{3})*[.,][0-9]{2}"
Local $sString = "1 000.00" & @CRLF & _
"1000,00" & @CRLF & _
"343 444.45" & @CRLF & _
"Subtotal, 1 000.00 EUR" & @CRLF & _
"VAT 1000,00" & @CRLF & _
"Total, sum: -343 444.45 EUR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")