using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?[0-9]{1,3}(?: ?[0-9]{3})*[.,][0-9]{2}";
string input = @"1 000.00
1000,00
343 444.45
Subtotal, 1 000.00 EUR
VAT 1000,00
Total, sum: -343 444.45 EUR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}