import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?[0-9]{1,3}(?: ?[0-9]{3})*[.,][0-9]{2}";
final String string = "1 000.00\n"
+ "1000,00\n"
+ "343 444.45\n"
+ "Subtotal, 1 000.00 EUR\n"
+ "VAT 1000,00\n"
+ "Total, sum: -343 444.45 EUR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}