package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?[0-9]{1,3}(?: ?[0-9]{3})*[.,][0-9]{2}`)
var str = `1 000.00
1000,00
343 444.45
Subtotal, 1 000.00 EUR
VAT 1000,00
Total, sum: -343 444.45 EUR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}