#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^! .+\n)+"
Local $sString = "! Multi-line quote" & @CRLF & _
"! Second line" & @CRLF & _
"Normal text" & @CRLF & _
"Normal text" & @CRLF & _
"! Single-line quote" & @CRLF & _
"Normal text" & @CRLF & _
"!Missing space" & @CRLF & _
"Normal text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")