$re = '/(^! .+\n)+/m';
$str = '! Multi-line quote
! Second line
Normal text
Normal text
! Single-line quote
Normal text
!Missing space
Normal text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);