import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^! .+\\n)+";
final String string = "! Multi-line quote\n"
+ "! Second line\n"
+ "Normal text\n"
+ "Normal text\n"
+ "! Single-line quote\n"
+ "Normal text\n"
+ "!Missing space\n"
+ "Normal text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}