package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^! .+\n)+`)
var str = `! Multi-line quote
! Second line
Normal text
Normal text
! Single-line quote
Normal text
!Missing space
Normal text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}