// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^! .+\n)+").unwrap();
let string = "! Multi-line quote
! Second line
Normal text
Normal text
! Single-line quote
Normal text
!Missing space
Normal text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}