re = /(^! .+\n)+/m
str = '! Multi-line quote
! Second line
Normal text
Normal text
! Single-line quote
Normal text
!Missing space
Normal text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end