package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d+)\.\h+(.+)(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?\RAns:\h+(.+)`)
var str = `1. Question with 4 choices
a. one a
b. one b
c. one c
d. one d
Ans: B
23. True-False Question with no choices
Ans: T
2. Question with 3 choices
a. two a
b. two b
c. two c
Ans: C
3. Question with 2 choices
a. three a
b. three b
Ans: B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}