// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?mi)(\d+)\.\h+(.+)(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?\RAns:\h+(.+)").unwrap();
let string = "1. Question with 4 choices
a. one a
b. one b
c. one c
d. one d
Ans: B
23. True-False Question with no choices
Ans: T
2. Question with 3 choices
a. two a
b. two b
c. two c
Ans: C
3. Question with 2 choices
a. three a
b. three b
Ans: B";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}