import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mi)(\\d+)\\.\\h+(.+)(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?\\RAns:\\h+(.+)";
final String string = "1. Question with 4 choices\n"
+ "a. one a\n"
+ "b. one b\n"
+ "c. one c\n"
+ "d. one d\n"
+ "Ans: B\n\n"
+ "23. True-False Question with no choices\n"
+ "Ans: T\n\n"
+ "2. Question with 3 choices\n"
+ "a. two a\n"
+ "b. two b\n"
+ "c. two c\n"
+ "Ans: C\n\n"
+ "3. Question with 2 choices\n"
+ "a. three a\n"
+ "b. three b\n"
+ "Ans: B";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}