const regex = /(?mi)(\d+)\.\h+(.+)(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?\RAns:\h+(.+)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?mi)(\\d+)\\.\\h+(.+)(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?(?:\\R[a-e]\\.\\h+(.+))?\\RAns:\\h+(.+)', 'gu')
const str = `1. Question with 4 choices
a. one a
b. one b
c. one c
d. one d
Ans: B
23. True-False Question with no choices
Ans: T
2. Question with 3 choices
a. two a
b. two b
c. two c
Ans: C
3. Question with 2 choices
a. three a
b. three b
Ans: B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}