# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\[((?:(?!\[\[).)*?)\|(.*?)]]/<a href="$1">$2<\/a>/gms;t' <<< "[[some_non-matching_text]] [[https://example.com|link]] [[this is not matching either]] [[http://example2.com|link2]]"