re = /\[\[((?:(?!\[\[).)*?)\|(.*?)]]/m
str = '[[some_non-matching_text]] [[https://example.com|link]] [[this is not matching either]] [[http://example2.com|link2]]'
subst = '<a href="$1">$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result