const regex = /\[\[((?:(?!\[\[).)*?)\|(.*?)]]/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[((?:(?!\\[\\[).)*?)\\|(.*?)]]', 'gms')
const str = `[[some_non-matching_text]] [[https://example.com|link]] [[this is not matching either]] [[http://example2.com|link2]]`;
const subst = `<a href="$1">$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);