import re
regex = re.compile(r"\[\[((?:(?!\[\[).)*?)\|(.*?)]]", flags=re.MULTILINE | re.DOTALL)
test_str = "[[some_non-matching_text]] [[https://example.com|link]] [[this is not matching either]] [[http://example2.com|link2]]"
subst = "<a href=\"$1\">$2</a>"
result = regex.sub(subst, test_str)
if result:
print(result)