use strict;
my $str = '[[some_non-matching_text]] [[https://example.com|link]] [[this is not matching either]] [[http://example2.com|link2]]';
my $regex = qr/\[\[((?:(?!\[\[).)*?)\|(.*?)]]/msp;
my $subst = '<a href="$1">$2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";