package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^reg0[1-4]\.eset\.com$`)
var str = `reg01.eset.com
reg02.eset.com
reg03.eset.com
reg04.eset.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}