$re = '/^reg0[1-4]\.eset\.com$/mi';
$str = 'reg01.eset.com
reg02.eset.com
reg03.eset.com
reg04.eset.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);