re = /^reg0[1-4]\.eset\.com$/mi
str = 'reg01.eset.com
reg02.eset.com
reg03.eset.com
reg04.eset.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end