// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^reg0[1-4]\.eset\.com$").unwrap();
let string = "reg01.eset.com
reg02.eset.com
reg03.eset.com
reg04.eset.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}