const regex = /^reg0[1-4]\.eset\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^reg0[1-4]\\.eset\\.com$', 'gmi')
const str = `reg01.eset.com
reg02.eset.com
reg03.eset.com
reg04.eset.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}