#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s+(?<my_field>\w+)$"
Local $sString = "I have the below set of events where I wanted to write regex to capture only the last word" & @CRLF & _
"I have the below set of events where I wanted to write regex to capture only the last" & @CRLF & _
"I have the below set of events where I wanted to write regex to capture only the" & @CRLF & _
"I have the below set of events where I wanted to write regex to capture only"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")