import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(?<my_field>\\w+)$";
final String string = "I have the below set of events where I wanted to write regex to capture only the last word\n"
+ "I have the below set of events where I wanted to write regex to capture only the last\n"
+ "I have the below set of events where I wanted to write regex to capture only the\n"
+ "I have the below set of events where I wanted to write regex to capture only";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}