$re = '/\s+(?<my_field>\w+)$/m';
$str = 'I have the below set of events where I wanted to write regex to capture only the last word
I have the below set of events where I wanted to write regex to capture only the last
I have the below set of events where I wanted to write regex to capture only the
I have the below set of events where I wanted to write regex to capture only';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);