// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+(?<my_field>\w+)$").unwrap();
let string = "I have the below set of events where I wanted to write regex to capture only the last word
I have the below set of events where I wanted to write regex to capture only the last
I have the below set of events where I wanted to write regex to capture only the
I have the below set of events where I wanted to write regex to capture only";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}