re = /\s+(?<my_field>\w+)$/m
str = 'I have the below set of events where I wanted to write regex to capture only the last word
I have the below set of events where I wanted to write regex to capture only the last
I have the below set of events where I wanted to write regex to capture only the
I have the below set of events where I wanted to write regex to capture only'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end