#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xi)" & @CRLF & _
"\.(3gpp?" & @CRLF & _
" |a(vi|sf|iff?)" & @CRLF & _
" |fl(ac|v)" & @CRLF & _
" |m(4a|ov|3u|id|kv|p\d+|pg\d*|peg\d*)" & @CRLF & _
" |ogg " & @CRLF & _
" |w(av|ebm|m[av])" & @CRLF & _
")"
Local $sString = ".m4a .wav .ogg .flac .avi .flv .mov .m3u .mid .webm .mkv .asf" & @CRLF & _
"" & @CRLF & _
".mpg .mpeg .mp10 .mpg10 .mpeg13 " & @CRLF & _
"" & @CRLF & _
".aif AND .aiff" & @CRLF & _
"" & @CRLF & _
".3gp AND .3gpp" & @CRLF & _
"" & @CRLF & _
".wma AND .wmv" & @CRLF & _
"bla.mp3 bla bla.mid.mp3.mp4.mid.mp10.mpeg.mpg.mpg10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")