use strict;
my $str = '.m4a .wav .ogg .flac .avi .flv .mov .m3u .mid .webm .mkv .asf
.mpg .mpeg .mp10 .mpg10 .mpeg13
.aif AND .aiff
.3gp AND .3gpp
.wma AND .wmv
bla.mp3 bla bla.mid.mp3.mp4.mid.mp10.mpeg.mpg.mpg10
';
my $regex = qr/
\.(3gpp?
|a(vi|sf|iff?)
|fl(ac|v)
|m(4a|ov|3u|id|kv|p\d+|pg\d*|peg\d*)
|ogg
|w(av|ebm|m[av])
)/xip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}