$re = '/
\.(3gpp?
|a(vi|sf|iff?)
|fl(ac|v)
|m(4a|ov|3u|id|kv|p\d+|pg\d*|peg\d*)
|ogg
|w(av|ebm|m[av])
)/xi';
$str = '.m4a .wav .ogg .flac .avi .flv .mov .m3u .mid .webm .mkv .asf
.mpg .mpeg .mp10 .mpg10 .mpeg13
.aif AND .aiff
.3gp AND .3gpp
.wma AND .wmv
bla.mp3 bla bla.mid.mp3.mp4.mid.mp10.mpeg.mpg.mpg10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);