// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xi)
\.(3gpp?
|a(vi|sf|iff?)
|fl(ac|v)
|m(4a|ov|3u|id|kv|p\d+|pg\d*|peg\d*)
|ogg
|w(av|ebm|m[av])
)").unwrap();
let string = ".m4a .wav .ogg .flac .avi .flv .mov .m3u .mid .webm .mkv .asf
.mpg .mpeg .mp10 .mpg10 .mpeg13
.aif AND .aiff
.3gp AND .3gpp
.wma AND .wmv
bla.mp3 bla bla.mid.mp3.mp4.mid.mp10.mpeg.mpg.mpg10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}